Skip to end of metadata
Go to start of metadata

Introduction

This is the documentation for the Vibes Push Notifications SDK. It provides an overview of the Vibes Push Notifications SDK for iOS and Android, and is meant for developers who want to have their systems interact with Vibes push notification technology.

Vibes offers this Push Notifications SDK to let you send push messages to consumers, track your app interactions with notifications, and allow mobile apps to register themselves to receive push messages from Vibes Mobile Engagement Platform.

Requirements for iOS

The following are the minimum iOS and Xcode versions that are required for the Vibes Push Notifications SDK.

  • iOS 9.0+, iOS 10.0+
  • Xcode 8.0+, Xcode 9.0+
  • CocoaPods 1.1.0+

Requirements for Android

The following is the minimum Android version that is required for the Vibes Push Notifications SDK.

  • Jelly Bean 4.1+

Prerequisites to Install the Vibes Push Notifications iOS SDK

You can use one of the following prerequisites to install the Vibes Push Notifications iOS SDK.

  • Cocoapads: You can use CocoaPods, which is a dependency manager for Cocoa projects, to install the Vibes Push Notifications iOS SDK.
  • Manual install. If you prefer not to use CocoaPods, you can manually integrate Vibes Push into your project.

Prerequisites to Install the Vibes Push Notifications Android SDK

  • Android Studio: Once you open Android Studio, it should handle downloading and syncing any of the Android SDK components it needs.

Environment

You will use test apps within a production environment to test your SDK. At production launch, you will switch to a production app within the production environment. 

Program Language for Apple iOS

You can build your iOS apps in Swift.

Program Language for Google Android

You can build your Android apps in Java or Kotlin.

  • No labels